HRP 261 SAS LAB THREE, February 1, 2012

Lab Three: importing data, sensitivity and specificity, ROC curves

Lab Objectives

After today’s lab you should be able to:

1. Import a dataset into SAS from excel. 
2. Use point-and-click screens to explore the data. 

3. Manipulate data in datasteps via code (PROC SORT, PROC RANK, PROC FORMAT).
4. Calculate sensitivity, specificity, PPV, NPV, and their confidence limits from a 2x2 table using code (PROC FREQ).

5. Understand the concept of an ROC curve.

6. Use logistic regression to generate data for an ROC curve.

7. If time (optional), run a simulation in SAS.

SAS PROCs                                     

SAS EG equivalent

PROC UNIVARIATE                             
Describe(Distribution Analysis
PROC GPLOT



Graph(Scatter Plot
PROC LOGISTIC



Analyze(Regression(Logistic regression
 LAB EXERCISE STEPS:

Follow along with the computer in front…

1. Go to the class website: www.stanford.edu/~kcobb/courses/hrp261 --> Download Lab Three DATA onto the desktop (Right click on the link, and then save the data on the desktop as an excel file: psa.xls.)

2. Back in SAS EG, name a SAS library hrp261 that points to the desktop as follows:

Go to Tools->Assign Project Library. Type hrp261 in the library Name box. Click Next.
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Browse to find your Desktop. Then click OK. Then Click Next.
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Click Next on step 3.

Click Finish to exit the new library screen.
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3. Use your explorer browser to make sure that an hrp261 library was created.

Click on Tools>SAS Enterprise guide Explorer
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Then click on Servers>Local>Libraries
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4. FYI, the SAS code to create a library is the following:
LIBNAME HRP261 "C:\ extension to your desktop…”;
5. Import the data from excel into SAS EG using point-and-click: 

a. Goto: File--> Import Data
b. Browse to find and select the file psa.xls in your desktop folder. Click Open. Click OK. 

c. Also browse to locate the HRP261 Library. Click on Save and then ->NEXT 
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Then click Finish. 

6. The first thing you should do when you get new data is to look at the data!

Examine the distributions of variables using point-and-click as follows:

From the menu select: Tasks(Describe(Distribution Analysis
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Highlight “capsule” variable and move it to the Task roles. Define it as “Analysis variable”
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On the left hand menu click on Plots->Appearance and check the Histogram Plot box. 
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On the left hand menu go to Tables and check the box Frequencies (to get frequency counts).
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Then click Run.
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7. Use Distribution Analysis to get univariate statistics and a histogram for the variable psa. 
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8. FYI, the basic code to get histograms in SAS is (with blue color):

PROC UNIVARIATE DATA = hrp261.psa;


VAR psa;


HISTOGRAM / CFILL=BLUE;

RUN; QUIT;
9. Now we want to see how psa capsule are related. To do so we will make a scatter plot of capsule and psa to analyze at their joint distribution. Click on 
Graph->Scatter Plot
[image: image14.png]SAS Enterprise Guide

Fle Edt Vew Tasks Progam  Tods Hep |E-G5- @& ¢ By B X |9 o |- [EegProcess Flow ~

=[G A © B3 It Data | 2] Code | (2] Log| @ Resuls|
No connection i Fiter and Sort. ElyQuery Buder | Data + Descrbe [ Graph | Andyze - | Export + Send To

capsule ag| B4 Bar Chartwizard vl gleason A
1 1 o Bl gar Chart, 1 [ s
B Eil 0 T 0 7
3 3 o €] Fie Chart wizard o 5
4 4 0 €| piechrt i) @ 7
5 | 5 L} BT ——— < ] 559 6
I 5 1 lig Line Plot Wizard. 3 o 8 ||
7 7 0 2] e Pl 0 7
| 8 0 e 272 7
| 3 0 L Scatter Flot, it o4 7
0| 0 o B wearit 5 o 5
J " T | -t char i o 7
= o i B ottt , L :
s | 1 1 € Donut Chart, 0 7
15 | 15 [ (| contour P | 0 5
16 ® 0 0 5
I EE il B Box Plot. - il 5
a8 | 18 o A Radar Chart, g s 5
19| 13 o B Surface Pt i 0 5
20 x 1 %5 7
B it T+ B Tie Chart, L o 7
22 | 2 1 # | Map Graph, 0 7
BE| 3 1 Create Map Feature Table, H 25 7
2 % 0 73 7
25 | % 1 7 0 61 58 7
2 | % 0 7 0 a8 0 5
27 | Bl 0 67 0 28 %6 7
28 | ] 0 7 0 23 141 5
29 | 2 0 64 0 56 M1 5
30 | 0 0 58 0 56 28 6
Ell i 1 54 0 a4 183 [
32 | 2 0 72 0 65 25 7
33 | B 0 7 0 1 0 8
3 | E) 1 60 0 95 0 7
3 | * 0 65 0 11 77 [
36 | * 0 il 0 73 0 7
37 | 7 0 54 0 1 0 [
38 | -} 1 8 0 272 0 8
39 | ki 1 63 0 kAN 187 7
a0 | a0 1 7 0 45 %4 7
| a 1 66 0 73 208 7
a2 | a2 0 il 0 2 0 [
43| 3 1 o 0 75 0 [
4| 4 0 72 0 53 0 7
a5 | 5 1 65 1 87 2 k]
45 | 4 1 7 i 3 152 8
a7 | 4 0 69 1 67 538 [
| “© o o o 23 63 5 8

Ready 4. 1 connecton





Select 2D Scatter Plot. Then select Data on the left hand menu
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Select capsule as the Horizontal axis variable and psa as the vertical axis variable
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What can you say about the joint distribution of Capsule and psa?
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10. Look at the distributions of a few of the other variables, and how they correlate with the distribution of capsule. Use these descriptive features of SAS to familiarize yourself with a new dataset and to check for outliers, missing data, and values that don’t make sense. (Hint: Use Modify Task to modify your original Distribution Analysis by adding more analysis variables).
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Drag in new analysis variables, such as age; then click Run.
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11. How good is the PSA test for predicting capsule=1 (the bad outcome)? We could dichotomize the results of the psa test and determine specificity and sensitivity from a two-by-two table. We’re going to do this part (where we’re manipulating the data) using code. To manipulate the code using point and click, you could also use the Query Builder feature (though I find this feature more difficult than coding).
proc sort data=hrp261.psa;

by psa;

run;



/*Break the data into quartiles using PROC RANK*/ 
proc rank data=hrp261.psa out=psa groups=4;

var psa;

ranks psaranks;

run;
/*In a datastep, create a new binary variable “test” that equals 1 if the man is in the top quartile of psa and 0 if he is not.*/

data psa;

set psa;

if psaranks=3 then test=1;

else if psaranks>=0 then test=0;

run;

/*Finally, use PROC FREQ to get sensitivity, specificity, PPV, and NPV. SAS will not automatically generate these values, but since they are just proportions, we can easily generate them. To get the confidence limits for the proportion (for the sensitivity, specificity, etc.), use the “exact binomial” option.*/

/*Sometimes we want to calculate the proportion where test=1 (sensitivity); sometimes we want to calculate the proportion where test=0 (specificity); sometime where capsule=1 (ppv) and sometimes where capsule=0 (npv). SAS will always calculate the proportion with the value “0” (because it comes first numerically), so we need to use a little trickery to get what we want. PROC FORMAT will help...*/

/*PROC FORMAT allows me to assign labels to numerical values. These labels appear in the output (for readability) and can also be used to change the order in tables from 0, 1 to 1, 0, e.g. when we want to calculate the proportion with the value “1” rather than “0”*/

proc format;

value disease

0="no disease"
1="disease"
;

run;
1. SENSITIVITY

Among men who truly have capsule=1, what proportion 

test positive (are in the top quartile of psa)?


proc freq data=psa order=formatted;

      tables test;

      exact binomial;


 where capsule=1;

      title 'Sensitivity';

format test disease.;
run;
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2. SPECIFICITY

Among men who truly have capsule=0, what proportion 

test negative (are in the lowest 3 quartiles of psa)?
proc freq data=psa;

      tables Test;

      exact binomial;


  where capsule=0;

      title 'Specificity';

run; 
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3. PPV

Among men who test positive, what proportion truly have capsule=1? 

proc freq data=psa order=formatted;

      tables capsule;

      exact binomial;


  where test=1;

      title 'Positive predictive value';


 format capsule disease.;

run;
Positive predictive value                                

	capsule
	Frequency
	Percent
	Cumulative
Frequency
	Cumulative
Percent

	disease
	64
	67.37
	64
	67.37

	no disease
	31
	32.63
	95
	100.00


	Binomial Proportion for capsule = disease

	Proportion (P)
	0.6737

	ASE
	0.0481

	95% Lower Conf Limit
	0.5794

	95% Upper Conf Limit
	0.7680

	 
	 

	Exact Conf Limits
	 

	95% Lower Conf Limit
	0.5698

	95% Upper Conf Limit
	0.7664


4. Do NPV using One-way Frequencies in point-and-click as follows:
Tasks(Describe(One Way Frequencies
In Data, move capsule to analysis variables.
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In Data, press Edit. 
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Select Test…Equal to… 0
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In Statistics, check both boxes under binomial proportions. 
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In Titles, click on analysis; uncheck the box for default text; enter Negative Predictive Value in the text box..
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Click Run
Results:
	Binomial Proportion for capsule = 0

	Proportion (P)
	0.6877

	ASE
	0.0275

	95% Lower Conf Limit
	0.6339

	95% Upper Conf Limit
	0.7415

	 
	 

	Exact Conf Limits
	 

	95% Lower Conf Limit
	0.6304

	95% Upper Conf Limit
	0.7411


12. What if we want to use a continuous predictor or multiple predictors rather than a binary cut-off? Logistic regression…

Though we have not covered logistic regression in class yet, the idea is to predict the probability of a binary outcome as a function of some predictors (here we will use the two diagnostic tests psa and gleason). 

How good of a diagnostic test for identifying capsule=1 (advanced cancer) is my logistic model (gleason + psa)? Make an ROC (Receiver-Operator Characteristic) curve.
The ROC curve plots the false positive rate on the X-axis and (1 - the false negative rate) on the Y-axis as a function of predicted probability (e.g., if I require a predicted probability of 100% to classify a man as having the disease, then my specificity will be perfect, but my sensitivity will be 0).

If the area under the ROC curve is close to 1, you have a very good test. If the area is close to 0.5, you have a lousy test (no better than chance). 

Click on Analyze->Regression->Logistic Regression
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Select Capsule as the dependent variable and gelason and psa as the predictors
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Click on Model->Response and select on Fit model to level 1
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On Model->Effects select gleason and psa as the main effects. Then Run
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In Model>Options check the box for “show classification table”. 
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In Plots, check Custom list of plots, and ask for the ROC Curve (the default is to give you all possible plots, but here we are only interested in the ROC curve; so this step narrows down the output plots). 
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Results:

	Analysis of Maximum Likelihood Estimates

	Parameter
	DF
	Estimate
	Standard
Error
	Wald
Chi-Square
	Pr > ChiSq

	Intercept
	1
	-7.6393
	1.0111
	57.0813
	<.0001

	psa
	1
	0.0267
	0.00893
	8.9257
	0.0028

	gleason
	1
	1.0593
	0.1583
	44.7674
	<.0001

	Odds Ratio Estimates

	Effect
	Point Estimate
	95% Wald
Confidence Limits

	psa
	1.027
	1.009
	1.045

	gleason
	2.884
	2.115
	3.934


The ROC curve looks like:
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The area under the ROC curve is .79
Ideally, the ROC curve should look like (approaching the upper left hand corner):
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So, our ROC curve here is OK, not great.
How does SAS generate the ROC curve? The model gives a predicted probability of capsule=1 for every observation (every unique combination of psa and gleason in the dataset). Using every predicted probability in the dataset as the cutoff for a positive test, SAS calculates sensitivity and 1-specificity as follows:

a. Start at the highest predicted probability (for this dataset, the person with the highest gleason and psa has a predicted probability of capsule=1 of 0.99639). 

b. Make this the cut-off for classifying a patient as test + (i.e., only patients who’s pred prob>= 0.99639 have a + test).

c. Using this cutoff, fill in the sensitivity/specificity 2x2 table:

	                        Truth

	Test 
	
	Capsule=1
	Capsule=0

	d. 
	+
	1
	0

	e. 
	-
	152
	227



Calculate sensitivity= 1/153=.00654

Calculate specificity= 227/227=100%

Interpretation: at such a high cut-off you won’t have any false positives (perfect specificity), but you’ll have tons of false negatives (low sensitivity).

f. Calculate 1-specificity = 100%-100% = 0.000  
g. Plot the point .00654, 0 on the ROC curve. 
h. Repeat for all unique predicted probabilities in the dataset (here 293). 

i. As another example, for the lowest predicted probability (.00049):

	                        Truth

	Test 
	
	Capsule=1
	Capsule=0

	j. 
	+
	153
	227

	k. 
	-
	0
	0


Calculate sensitivity= 153/153=100%

Calculate specificity= 0/227=0%

Interpretation: at such a high cut-off you won’t have any false negatives (perfect sensitivity), but you’ll have tons of false positives (low specificity).

l. 1-specificity= 1-0 = 100%
m. Plot the point 100%, 100%
The Classification Table displays sensitivity and specificity values for various predicted probabilities:
	Classification Table

	Prob
Level
	Correct
	Incorrect
	Percentages

	
	Event
	Non-
Event
	Event
	Non-
Event
	Correct
	Sensi-
tivity
	Speci-
ficity
	False
POS 
	False
NEG 

	0.000
	153
	0
	227
	0
	40.3
	100.0
	0.0
	59.7
	.

	0.020
	153
	2
	225
	0
	40.8
	100.0
	0.9
	59.5
	0.0

	0.040
	153
	2
	225
	0
	40.8
	100.0
	0.9
	59.5
	0.0

	0.060
	153
	3
	224
	0
	41.1
	100.0
	1.3
	59.4
	0.0

	0.080
	153
	3
	224
	0
	41.1
	100.0
	1.3
	59.4
	0.0

	0.100
	151
	26
	201
	2
	46.6
	98.7
	11.5
	57.1
	7.1

	0.120
	149
	55
	172
	4
	53.7
	97.4
	24.2
	53.6
	6.8

	0.140
	147
	59
	168
	6
	54.2
	96.1
	26.0
	53.3
	9.2

	0.160
	147
	62
	165
	6
	55.0
	96.1
	27.3
	52.9
	8.8

	0.180
	147
	63
	164
	6
	55.3
	96.1
	27.8
	52.7
	8.7

	0.200
	147
	64
	163
	6
	55.5
	96.1
	28.2
	52.6
	8.6

	0.220
	146
	65
	162
	7
	55.5
	95.4
	28.6
	52.6
	9.7

	0.240
	136
	100
	127
	17
	62.1
	88.9
	44.1
	48.3
	14.5

	0.260
	120
	135
	92
	33
	67.1
	78.4
	59.5
	43.4
	19.6

	0.280
	115
	156
	71
	38
	71.3
	75.2
	68.7
	38.2
	19.6

	0.300
	115
	160
	67
	38
	72.4
	75.2
	70.5
	36.8
	19.2

	0.320
	115
	161
	66
	38
	72.6
	75.2
	70.9
	36.5
	19.1

	0.340
	115
	161
	66
	38
	72.6
	75.2
	70.9
	36.5
	19.1

	0.360
	113
	162
	65
	40
	72.4
	73.9
	71.4
	36.5
	19.8

	0.380
	113
	162
	65
	40
	72.4
	73.9
	71.4
	36.5
	19.8

	0.400
	113
	163
	64
	40
	72.6
	73.9
	71.8
	36.2
	19.7

	0.420
	113
	164
	63
	40
	72.9
	73.9
	72.2
	35.8
	19.6

	0.440
	113
	164
	63
	40
	72.9
	73.9
	72.2
	35.8
	19.6

	0.460
	113
	165
	62
	40
	73.2
	73.9
	72.7
	35.4
	19.5

	0.480
	100
	170
	57
	53
	71.1
	65.4
	74.9
	36.3
	23.8

	0.500
	87
	178
	49
	66
	69.7
	56.9
	78.4
	36.0
	27.0

	0.520
	80
	188
	39
	73
	70.5
	52.3
	82.8
	32.8
	28.0

	0.540
	75
	199
	28
	78
	72.1
	49.0
	87.7
	27.2
	28.2

	0.560
	63
	202
	25
	90
	69.7
	41.2
	89.0
	28.4
	30.8

	0.580
	57
	203
	24
	96
	68.4
	37.3
	89.4
	29.6
	32.1

	0.600
	53
	208
	19
	100
	68.7
	34.6
	91.6
	26.4
	32.5

	0.620
	50
	211
	16
	103
	68.7
	32.7
	93.0
	24.2
	32.8

	0.640
	50
	212
	15
	103
	68.9
	32.7
	93.4
	23.1
	32.7

	0.660
	48
	214
	13
	105
	68.9
	31.4
	94.3
	21.3
	32.9

	0.680
	47
	214
	13
	106
	68.7
	30.7
	94.3
	21.7
	33.1

	0.700
	45
	214
	13
	108
	68.2
	29.4
	94.3
	22.4
	33.5

	0.720
	43
	215
	12
	110
	67.9
	28.1
	94.7
	21.8
	33.8

	0.740
	40
	216
	11
	113
	67.4
	26.1
	95.2
	21.6
	34.3

	0.760
	38
	218
	9
	115
	67.4
	24.8
	96.0
	19.1
	34.5

	0.780
	38
	222
	5
	115
	68.4
	24.8
	97.8
	11.6
	34.1

	0.800
	33
	224
	3
	120
	67.6
	21.6
	98.7
	8.3
	34.9

	0.820
	31
	224
	3
	122
	67.1
	20.3
	98.7
	8.8
	35.3

	0.840
	28
	224
	3
	125
	66.3
	18.3
	98.7
	9.7
	35.8

	0.860
	26
	226
	1
	127
	66.3
	17.0
	99.6
	3.7
	36.0

	0.880
	23
	226
	1
	130
	65.5
	15.0
	99.6
	4.2
	36.5

	0.900
	21
	226
	1
	132
	65.0
	13.7
	99.6
	4.5
	36.9

	0.920
	14
	226
	1
	139
	63.2
	9.2
	99.6
	6.7
	38.1

	0.940
	9
	227
	0
	144
	62.1
	5.9
	100.0
	0.0
	38.8

	0.960
	8
	227
	0
	145
	61.8
	5.2
	100.0
	0.0
	39.0

	0.980
	4
	227
	0
	149
	60.8
	2.6
	100.0
	0.0
	39.6

	1.000
	0
	227
	0
	153
	59.7
	0.0
	100.0
	.
	40.3


13. OPTIONAL CODING EXERCISE (If you get ahead). Simulation: simulate the sampling distribution of the odds ratio and of the natural log of the odds ratio using this code:

/** This program simulates the results of 1000 case-control studies, where you can vary the true odds ratio in the population (e.g., the true association between exposure and disease) and the true prevalence of disease in the controls (initially set at 1.0 and 20%)**/ 

/**For each simulated study, SAS draws a sample of 50 cases and 50 controls; determines how many are exposed in each group (using a random binomial function); and calculates an odds ratio (OR) and an lnOR**/

/**The program then plots a histogram of the 1000 simulated ORs (or lnORs)**/ 
%LET OR=1.0;

%LET pe=.20;

%LET NCase=50;

%LET NControl=50;

%LET SIM=1000;

%LET seed=10;


data simulate1;


pe_d=(&pe*&OR)/(&OR*&pe+1-&pe);

    do i=1 to &sim by 1;

            a = ranbin(&seed, &NCase, pe_d);

            b = ranbin(&seed, &NControl, &pe);

            c = &NCase-a;

            d = &NControl-b;

            ORhat = (a*d)/(b*c);




 lnOR = log((a*d)/(b*c));


           output;

    end;

run;

title "Simlulated results from &sim. case-control studies";

proc univariate data=SIMULATE1 noprint;

         pattern1 color = red;


    label orhAT="Observed odds ratio";


    label lnoR= "Observed natural log of the odds ratio";

         var orhat lnor;

         histogram;

run;

NOW try varying the OR, proportion exposed, number of simulations, etc. to see how everything changes!














































































Specificity is better….





Since I want to get the proportion with test=0, I allow SAS to use numerical order, so 0 comes first and 1 second (i.e., I don’t apply a format).





A sensitivity of 41% is not too great!





Confidence interval= 34% to 50%.








Add a title to your output to make your life easier!














Get a histogram from proc univariate.





I’ve fancied it up a bit with a title, labels, and red color.





Example of what happens in 1 loop:





*SAS picks a random variable from a binomial distribution with N=50 and p=.20 This is the number of exposed cases.





*SAS does the same thing to get the number of exposed controls. 





*Unexposed cases = 50 – exposed cases





*Unexposed controls = 50 – exposed controls





*Calculate OR, lnOR


*Output these to a dataset.





Loop through 1000 times and each time output the resulting OR and lnOR



































NPV=68% (95%CI: 63% to 74%)





To call a pre-set variable, add an ampersand to the front.





Set the following parameters at the front of the program, so that you can more easily change them later. 











Apply the “disease” format to the variable test.





restricts the analysis only to the men who have capsule=1 (who truly have the outcome!). So we get the proportion who tested positive among those who actually have the disease.





Order the variables by their labels, rather than numerically. Thus, 1 comes before 0 (d before n).





Name the format anything you want.





PPV = 67.4%





out=newdataset : specifies the name of the new dataset that will contain the ranked variable (avoid writing over your old dataset—always precarious!)


groups specifies how many ranks you want (will run from 0 to #groups-1)


ranks statement names a new variable that will contain the ranks—if you omit the ranks statement SAS will write over the old variable with the ranks, and you will lose the original values.


var statement specifies which variable you want ranked. 





groups=4 tells SAS you want quartiles.


To get tertiles, use groups=3.


For quintiles, use groups=5.


Etc.





Both psa and gleason are significant predictors of capsule=1. 





**PROC RANK will not work unless you use PROC SORT first to order your data by the variable you want to rank.
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