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ME220 Lab #1 

Introduction to LabView Environment and Signals in the  

Time and Frequency Domain 

 
Lab Report Due:  4/15/08, before 5:00 pm, outside Terman 538 

 

Before you start:  

 
Form a Lab Team.  For later labs, you’ll need a lab kit, and we need to know who the 

teams are in order to build enough lab kits.  Your lab team should be 2 or 3 people, and 

you should be able to arrange schedules so that you’re able to work together.  Most lab 

exercises will take 3-5 hours.   

 

We want you to work together in small groups, mainly because that is more efficient use 

of the lab facilities.  Also, you can learn more working in a group than on your own.  

Hopefully, these labs are more fun in small groups than on your own. 

 

The lab is available for use 24 hours/day, 7 days/week.  There are 8 workstations suitable 

for these exercises in the lab, so there should be plenty of capacity. 

 

1. Go to the lab  (Terman 577, Door Combo 52413) 

2. Log onto a station, making sure the computer is set to the WIN domain.  

Username and Password are the same as your regular SUNet ID.  All the files you 

need will be at : U:\220_student.  Warning! The startup may be painfully slow.  

This will be a nice exercise in patience. 

3. Create a folder with your team name inside the U:\220_student folder – this will 

be the location where you save your work during this quarter. 

 

Goals of this Lab : 

 Many of you have never used LabView for measurements.  It is a common tool in 

experimental research, industrial product development, and manufacturing operations.  

You’ll eventually have many chances to use this tool in research or in a job.  In this 

course, we want to use it to carry out some experiments and to provide some efficient 

analyses of the resulting data.  The goal of this Lab is to get you all up to speed on some 

of the features of LabView, and to use the LabView environment to learn some useful 

things about time-domain and frequency-domain analysis of some simple signals. 

 If you’re a LabView “Veteran”, there will be some old, familiar material in this 

exercise, but there are some Features of LabView 7.0 that you will see for the first time 

and hopefully appreciate. 

 

Acknowledgement 

 Zachary Nelson of National Instruments orchestrated a donation of the LabView 

Software and the National Instruments Data Acquisition hardware that we’ll be using in 

the lab this quarter.  Zach will visit sometimes during the quarter, so please be nice to 

him! 
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Exercise 0 - Open and Run a Virtual Instrument 
 

The goal of this section is to examine the Signal Generation and Processing virtual 

instrument (VI) and run it, change the frequencies and types of the input signals, and 

notice how the display on the graph changes.  You’ll get some experience changing the 

Signal Processing Window and Filter options.  

 

Open U:\220_student\Lab 1 and click on <Signal Generation and Processing.VI>.  Ignore 

any warning messages that appear and close the warnings window.  Close the “Controls” 

window if it appears. 

 

Front Panel 

1. Click the Run button on the toolbar, (looks like an Arrow, positioned on the 

top left corner right under the “edit” pull-down) to run this VI. 

This VI generates a pair of time-dependent functions (set by the controls on the 

upper left), and shows what happens to those signals during the formation of a 

Fast Fourier Transform of the signals. This example also displays the power 

spectrum that results from a FFT for the generated signal. The resulting  

signals are displayed in the graphs on the front panel, as shown in the 

following figure.  Try turning one of the sources off to play around with just a 

single signal.  See comment below for more info. 

 

 
 

2. Use the Operating tool, shown at left, to change the parameters of your wave 

function.  For example, you can change the type of input signal, change the 

frequency of an input signal using the slider, or change the filter used on the 

signal. 
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3. Press the More Info… button or [F5] to read more about the analysis functions. 

 

4. Press the Stop button or [F4] to stop the VI. 

 

 
Block Diagram 

 

5. Select Window»Show Diagram or press the <Ctrl-E> keys to display the 

Block Diagram for the Signal Generation and Processing VI. 

 

This Block Diagram contains several of the basic Block Diagram elements, 

including subVIs, functions, and structures, which you will learn about later in 

this course. 

 

6. Select Window»Show Panel or press the <Ctrl-E> keys to return to the Front 

Panel. 

 

7.  Close the VI and do not save changes. 

 
End of Exercise 

 

Comments:  This VI is a nice demonstration of how the FFT works in real instruments.  

The incoming waveform is usually measured over some finite time interval, and the 

beginning and end of the signal over this interval is usually abrupt.  The FFT assumes 

that the signal is periodic, so it is necessary to smooth out the beginning and end.  The 

various “window” functions do this in different ways with different effects on the shape 

of peaks.  This exercise allowed you to explore the relationship between the time-domain 

view of the signal and the frequency-domain view of the same signal and to investigate 

the effect of filters on the signal, although don’t worry if you don’t understand the 

differences between all the filter types.  We’ll do more of this exploring in exercise #4. 
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Exercise 1 – Convert °°°°C to °°°°F 

 

Build a VI 
 

Complete the following steps to create a VI that takes a number representing degrees 

Celsius and converts it to a number representing degrees Fahrenheit. This should help 

you gain familiarity with the processes for building your own .vi and getting it to work. 

 

In wiring illustrations, the arrow at the end of this mouse icon shows where to click and 

the number on the arrow indicates how many times to click. 

 

Front Panel 
1. Inside the Lab 1 Folder, open Blank.vi.  Close the controls window if it starts 

out open. 

 

 

 

 

 

2. Select Window»Tile Left and Right (or press CTRL+t) to display the front 

panel and Block Diagram side by side. 

3. Create a numeric digital control by using the following steps. You will use 

this control to enter the value for degrees Centigrade. 

a. Select the Num Ctrl on the Controls»NumCtrls palette. If the 

Controls palette is not visible, right-click an open area on the front 

panel to display it (NOTE: right-clicking on the Front Panel and Block 

Diagram give you different toolbars (Controls and Functions, 

respectively). 

b. Move the control to the front panel and click to place the control. 

c. Type deg C inside the label and click outside the label or click the 

Enter button on the toolbar. If you do not type the name immediately, 

LabVIEW uses a default label. You can edit a label at any time by 

using the Labeling tool, which can be found under Windows>>Show 

Tools Palette. 

4. Create a numeric digital indicator by using the following steps. You will use 

this indicator to display the value for degrees Fahrenheit. 

a. Select the Num Ind on the Controls»NumInds palette. 

b. Move the indicator to the front panel and click to place the indicator. 

c. Type deg F inside the label and click outside the label or click the 

Enter button. 

Note:  LabVIEW creates corresponding control and indicator terminals on the 

Block Diagram (which will be on the right side of your screen if you chose to 

follow step 2 above). The terminals represent the data type of the control or 

indicator. For example, a DBL terminal represents a double-precision, floating-

point numeric control or indicator. 

Note:  Control terminals have a thicker border than indicator terminals. 
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Block Diagram 
 

 
 

Note:  Block Diagram terminals can be viewed as icons or as terminals.  To 

change the way LabVIEW displays these objects right click on a terminal and 

select View As Icon.   

 

 
 

 

5. Bring up the toolbar for the Block Diagram (remember that right click!).  

Choose Arith/Compare>>Numeric.  Place one of the Multiply functions 

and one of the Add functions on the Block Diagram. 

6. Select the numeric constant on the Arith/Compare»Numeric palette and 

place two of them on the Block Diagram. When you first place the numeric 

constant, it is highlighted so you can type a value. 

7. Type 1.8 in one constant and 32.0 in the other.  If you moved the constants 

before you typed a value, use the Labeling (Window>>Show Tools Palette) 

tool to enter the values. 

8. Use the Wiring tool (looks like a spool on the Tools Palate) to wire the icons 

as shown in the previous Block Diagram. Instructions for using the Wiring 

tool are given below. 

a. To wire from one terminal to another, use the Wiring tool to click the first 

terminal, move the tool to the second terminal, and click the second 

terminal, as shown in the following illustration. You can start wiring at 

either terminal. 
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b. You can bend a wire by clicking to tack the wire down and moving the 

cursor in a perpendicular direction. Press the spacebar to toggle the wire 

direction. 

c. To identify terminals on the nodes, right-click the Multiply and Add 

functions and select Visible Items»Terminals from the shortcut menu to 

display the connector pane. Return to the icons after wiring by right-

clicking the functions and selecting Visible Items»Terminals from the 

shortcut menu to remove the checkmark. 

d. When you move the Wiring tool over a terminal, the terminal area blinks, 

indicating that clicking will connect the wire to that terminal and a tip strip 

appears, listing the name of the terminal. 

e. To cancel a wire you started, press the <Esc> key, right-click, or click the 

source terminal.  Also, when you’re done with the wiring tool (or any 

other of the tools) you can press space bar to stop using it. 

9. Display the front panel by clicking it or by selecting Window»Show Panel. 

10. Save the VI because you will use this VI later in the course. 

a. Select File»Save as. 

b. Navigate to the folder you created for your group’s work and save 

there. 

11. Enter a number in the digital control and run the VI by following the steps 

below. 

a. Use the Operating tool (looks like a hand) or the Labeling tool (looks 

like an “A”) to double-click the digital control and type a new number. 

b. Click the Run button (same arrow as in Exercise 0) to run the VI. 

c. Try several different numbers and run the VI again. 

12. Save changes.  Select File»Close to close the Convert C to F VI. 

 

End of Exercise 
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Exercise 2 – Create a SubVI 
 

This exercise will give you more experience in building operational .vi files 

 

Front Panel 
1. Select File»Open and navigate to your group’s folder to open the Convert C 

to F VI created in the last exercise. 

 

Tip Click the arrow next to Open… button on the LabVIEW dialog box to open recently 

opened files, such as Convert C to F.vi. 

The following front panel appears. 

 
2. Right-click the icon in the upper right corner of the menu bar and select Edit 

Icon from the shortcut menu. The Icon Editor dialog box appears. 

3. Double-click the Select tool on the left side of the Icon Editor dialog box to 

select the default icon. 

4. Press the <Delete> key to remove the default icon. 

5. Double-click the Rectangle tool to redraw the border. 

6. Create the following icon using the following steps. 

 

 
a. Use the Text tool to click the editing area. 

b. Type C and F. 

c. Double-click the Text tool and change the font to Small Fonts. 

d. Use the Pencil tool to create the arrow. 

Note To draw horizontal or vertical straight lines, press the <Shift> key while you 

use the Pencil tool to drag the cursor. 

e. Use the Select tool and the arrow keys to move the text and arrow you 

created. 



 8

f. Select the B&W icon and select 256 Colors in the Copy from field to 

create a black and white icon, which LabVIEW uses for printing 

unless you have a color printer. 

g. When the icon is complete, click the OK button to close the Icon 

Editor dialog box. The icon appears in the upper right corner of the 

front panel and Block Diagram. 

7. Right-click your new icon on the front panel and select Show Connector 

from the shortcut menu to define the connector pane terminal pattern. 

LabVIEW selects a connector pane pattern based on the number of controls 

and indicators on the front panel. For example, this front panel has two 

terminals, deg C and deg F, so LabVIEW selects a connector pane pattern 

with two terminals. 

8. Assign the terminals to the digital control and digital indicator by doing the 

following. 

a. Select Help»Show Context Help to display the Context Help 

window. View each connection in the Context Help window as you 

make it. 

b. Click the left terminal in the connector pane. The tool automatically 

changes to the Wiring tool, and the terminal turns black. 

c. Click the deg C control. The left terminal turns orange (indicating that 

it is a floating point number), and a marquee highlights the control. 

d. Click an open area of the front panel. The marquee disappears, and the 

terminal changes to the data type color of the control to indicate that 

you connected the terminal. 

e. Click the right terminal in the connector pane and click the deg F 

indicator. The right terminal turns orange. 

f. Click an open area on the front panel. Both terminals are orange. 

g. Move the cursor over the connector pane. The Context Help window 

shows that both terminals are connected to floating-point values. 

9. Select File»Save to save the VI because you will use this VI later in the 

course. 

10. Select File»Close to close the Convert C to F VI. 

 

End of Exercise 
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 Exercise 3 – Using Loops 

 
Use a while loop and a waveform chart to build a VI that demonstrates software timing.  

 

Front Panel 
1. Open a new VI. 

2. Build the following front panel with the following instructions. 

 

 
 

a. Select the horizontal pointer slide on the Controls»Numeric Controls 

palette and place it on the front panel. You will use the slide to change the 

software timing. 

b. Type millisecond delay inside the label and click outside the label. 

c. Select a waveform chart on the Controls»Graph Indicators palette and 

place it on the front panel. The waveform chart will display the data in real 

time. 

d. Type Value History inside the label and click outside the label. 

e. The waveform chart legend labels the plot Plot 0. Use the Labeling tool 

to triple-click Plot 0 in the chart legend, type Value, and click outside 

the label or click the Enter button to relabel the legend. 

f. Use the Labeling tool to double-click 10.0 in the y-axis, type 1, and 

click outside the label or click the Enter button to rescale the chart. 

g. Change –10.0 in the y-axis to 0. 

h. Label the y-axis Value and the x-axis Time (sec). 
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Block Diagram 

 
3. Select Window»Show Diagram to display the Block Diagram (or press 

CTRL+t). 

 

4. Enclose the two terminals in a While Loop, as shown in the following Block 

Diagram. 

 
a. Select the While Loop on the Functions»Execution Control palette. 

b. Click and drag a selection rectangle around the two components of the 

Block Diagram.  A stop button will appear after you draw the loop. 

c. Use the Positioning tool to resize the loop, if necessary. 

 

5. Select the Random Number (0-1) on the Functions»Arithmetic and 

Comparison»Numeric palette. Alternatively you could use a VI that is 

gathering data from an external sensor. The random number generator 

generates numbers between 0 and 1, and is a nice simulation of a noisy signal 

for this exercise. 

6. Wire the Block Diagram objects as shown in the previous Block Diagram. 

7. Save the VI as Use a Loop.vi because you will use this VI later in the 

course. 

8. Display the front panel by clicking it or by selecting Window»Show Panel. 

9. Run the VI. 

The section of the Block Diagram within the While Loop border executes 

until the specified condition is TRUE. For example, while the STOP button is 

not pressed, the VI returns a new number and displays it on the waveform 

chart. 

10. Click the STOP button to stop the acquisition. The condition is FALSE, and 

the loop stops executing. 

11. Format and customize the X and Y scales of the waveform chart. 
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a. Right-click the chart and select Properties from the shortcut menu. 

The following dialog box appears. 

b. Click the Scale tab and select different styles for the y-axis. You also 

can select different mapping modes, grid options, scaling factors, and 

formats and precisions.  Notice that these will update interactively on 

the waveform chart 

c. Select the options you desire and click the OK button. 

 

 
 

12. Right-click the waveform chart and select Data Operations»Clear Chart 

from the shortcut menu to clear the display buffer and reset the waveform 

chart. If the VI is running, you can select Clear Chart from the shortcut 

menu. 

 

Adding Timing 
When this VI runs, the While Loop executes as quickly as possible. Complete the 

following steps to take data at certain intervals, such as once every half-second, as shown 

in the following Block Diagram.  
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13. Place the Time Delay Express VI located on the Functions»Execution 

Control palette. In the dialog box that appears, insert 0.5.  This function 

would make sure that each iteration occurs every half-second (500 ms) as the 

default value, but we will override this default with a separate input (next 

step). 

14. Divide the millisecond delay by 1000 to get time in seconds.  Connect the 

output of the divide function to the Delay Time (s) input of the Time Delay 

Express VI.  This will allow you to adjust the speed of the execution from the 

pointer slide on the front panel. 

15. Save the VI, because you will use this VI later in the course. 

16. Run the VI. 

17. Try different values for the millisecond delay and run the VI again.  Notice 

how this effects the speed of the number generation and display. 

18. Close the VI. 

 

End of Exercise 
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Exercise 4 – Building Your Own Source and Analyzer 
 

Complete the following steps to build a VI that generates waveforms, filters the 

waveforms, and analyzes the resulting waveform in the time domain and the frequency 

domain.  This relies on steps you’ve already carried out. 

 

Block Diagram 

1. Open a new, Blank VI 
2. On the Block Diagram, select Functions » Input » Sim Signal   This creates 

a variable frequency signal source – something like a virtual function 

generator.  Change settings to Square Wave, 5 Hz, Amplitude = 1, Add Noise 

On, (uniform noise with amplitude of 0.4).  In the timing box, set samples per 

second to 5000, uncheck the “Automatic” box, and set the Number of Samples 

to 5,000.  If you want to edit the properties later, you can double-click on the 

icon. 
3. Select Functions » Analysis » Filter.  This creates a variable signal filter that 

can be used to change the signal from the function generator.  Double click on 

the icon and set it for low-pass, 70 Hz, First-Order Butterworth.  The different 

filter types represent variations in the design of a multiple-order filter that 

feature different cutoff shapes, different phase response, and different 

amounts of attenuation near the corner frequency of the filter. 
4. Use the wire tool to connect the output of the function generator to the input 

of the filter. 
5. Create a graph (not a chart) indicator (from the front panel menu) at the 

output of the function generator so that you can see the waveform on the front 

panel. 
6. Turn the vi on and look at the waveform as you change the settings for the 

source. 
7. Create a new graph indicator at the output of the filter, so that you can look at 

the filtered signal.   
8. Turn the vi on again, and change the filter settings to see the effect on the 

waveform.  See what happens if the filter frequency is set close to and then 

below the frequency of your signal.  Be sure to look at squarewaves and 

triangle waves to see the effect of the lowpass filter on the filtered waveform.  
9.  Select Functions » Analysis » Spectral to create a Frequency Analysis of the 

signal.  This function computes the Fourier Transform of the input signal and 

displays the result.  This result appears as a Power Spectral Density as a 

function of Frequency, and allows easy determination of the frequency 

distribution of the signal. 
10. Use the wire tool to connect the output of the filter to the input of the 

frequency analyzer. 
11. Create a new graph indicator at the output(FFT-(RMS))of the frequency 

analyzer. 
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Now, you’ve built a signal source, a filter, and a signal analyzer, and hooked them all up 

together.  This system can be used to explore the relationship between the input signal 

and the filtered signal in the time domain and the frequency domain.  Carry out the 

following exercises and report the results in a Lab Report. 

 

A) Measure the frequency content of a square wave.  Set the source to 25 Hz 

Square wave with no noise.  Set the filter frequency to 1000 Hz (this should set 

things so that the filter does not change the waveform at all).  Look at the output 

of the spectral analysis.  You will probably need to adjust the plot (click on the 

plot and open the “properties” window.  Adjust the frequency range to 0-250 Hz, 

and change other settings as needed to allow you to see the response.)   You 

should see a series of peaks in the spectral measurement.  What frequencies 

appear here?  Can you explain why these frequencies appear?   What is the 

amplitude of the first 3 peaks? 

 

(Measure by right-clicking on the plot and scrolling to “visible items” and “cursor 

legend”, and then right click on the legend (which may be hidden off screen) and 

scroll to “properties” and select “cursors”  Add cursor and set “allow dragging” 

and “snap to point”.  With these settings, you should be able to drag the cursor 

laterally across the plot and read the values from the display.  This allows 

measurement of the peak heights) 

 

B)  Now, change the cutoff frequency of the filter to 100 Hz.  Run the vi, and 

describe the differences in the shape of the waveform at the output of the filter.  

Measure the peak heights in the frequency plot and compare with the results from 

before.  Explain what is happening. 

 

C) Now, change the filter cutoff frequency to 30 Hz.  Change the filter from 

Butterworth to the other choices, and change the order from 1 to other numbers up 

to 6.  Look at the output of the filter and at the frequency analysis and explain 

what is happening .  For a 4
th

 order butterworth at 30 Hz, what is the height of the 

first 3 peaks in the frequency plot. 

 

D) Change the filter settings back to 100 Hz cutoff and first-order 

Butterworth.  Change from Squarewave to Sinewave in the frequency source.  

Describe what happens to the frequency domain plot and explain the differences. 

 

E)  Change the source to Sawtooth.  What has changed in the frequency plot?  

There should be some new peaks.  Can you explain why these new peaks appear?   

 

F)   Now, we’re going to explore the relationship between the formation of the 

function and the ability to analyze the function.  In the Simulate Signal Window, 

The Samples per second and number of samples were both set to 5000.  This 

creates a function (sawtooth in this case) that is digitally generated by changing 

the “signal” 5000 times per second to follow the 25 Hz waveform, and displays an 

entire second of data in the window.  If we change the Number of samples, the 
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result is that the amount of data in the result will change. Change to 500 samples 

and see.  Now, close the simulate signal window and look at the result – the 

Waveform in the input and output windows has fewer oscillations, and the FFT 

has many fewer points.  What is going on here?   

Without going into too many details about the FFT, there are a few simple rules to 

remember.  When taking data for a FFT, there are 2 real-time numbers that 

matter:  the interval between samples and the total interval of the scan.  In the 

FFT output, the total range of frequencies that can come out is 1/2 of the sampling 

rate.  (to see this, right click on the fft plot, select properties>>scales and set the 

x-axis to autoscale.  This will force the plot to display the entire range of available 

data.  In this case, the data will go from 0-2500 Hz) 

 

The other simple number is that the interval between data points in the FFT (in 

Hz) will be the reciprocal of the total interval of the scan.  With the present 

settings (5000 samples per second, 500 total samples), the total interval is 1/10 of 

a second, and the interval in the FFT is 10 Hz.  Since we’re interested in seeing 

the peaks with more resolution than this, we need to increase the total sweep time 

of the plot.  This can be done by reducing the sample rate from 5000 samples/sec 

to something lower (like 500), or by increasing the total number of samples from 

500 to something higher (like 5000).  Try these both and describe the difference. 

 

Throughout this quarter, we’ll be doing time-domain and frequency-domain 

analysis of signals.  As you’ve seen, both views are interesting and valuable for 

determining what is going on with a signal.  In the time domain, you can see what 

it looks like, how big it is, and roughly what the signal/noise ratio is.  In the 

frequency domain, you can see how the signal and noise are distributed, what 

frequency components are included with the signal, and what things can be 

accomplished by filtering.  To be able to make all this meaningful, you need to 

know a little about the Fourier Transform, and the point of this exercise is to 

explore this for the first time (for some of you), and to refresh the details (for 

some of you).  We’ll definitely be returning to these kinds of measurements, so be 

sure to remember that there are a lot of things to set properly for the time and 

frequency domain displays to be useful. 

 

End of Exercise 

 

Note – in all these exercises, we’re exploring how a waveform is constructed of  

collections of sinewaves at various harmonics of the fundamental frequency.  By 

looking at the frequency domain, we’re able to measure the frequencies and 

amplitudes of those added components that are required to build the squarewaves 

or other waveforms.  As filter settings are adjusted, you’re attenuating or 

eliminating some of the added components that are necessary to construct the 

waveforms, and the resulting distorted waveforms reflect this removal of needed 

components.   
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During this quarter, we’re going to be discussing signals and noise, and one 

important method for separating them (reducing the noise and increasing the 

signal) is by filtering and by looking at the results in the time domain and the 

frequency domain.  We’re going to rely a lot on the frequency domain to 

understand what the noise and signals look like and to help improve the 

signal/noise ratio.  So, these first exercises are important for beginning to build 

some expertise about frequency domain measurements. 

 


